SMS and WhatsApp Opt-In flows are automatic messages designed to meet regulations that require consumers to have the option of accepting or rejecting communications from business. MultiLine allows your organization to configure these Opt-In messages for their users (Learn More).
When you attempt to contact someone they receive a message with instructions on how to opt-in. If they opt-out, they are notified of this and receive instruction about how to opt-in again, if desired.
Unless your organization configured a custom flow, usually the person just needs to reply to the message thread with “YES”. They also have the option to reply to the conversation with any other message, and a new opt-in message will be sent to the user giving them another chance to consent to message with you.
Why do I see “The contact hasn't responded to the opt-in request for more than 24 hours. You can try sending the request again.”?
In order for you to message with a client, they must accept your opt-in request. You’re allowed to send a new one every 24 hours. If accepted, you’ll be able to message with the customer. If it’s rejected, we’ll let you know, and you won’t be able to send any more opt-in requests to the customer.
Why did a client receive the auto message “. . . We're not currently using this number to accept WhatsApp messages.”?
The MultiLine administrator at your company has deactivated WhatsApp for your number. Contact them to resolve.
This article provides information and a workaround for a number formatting scenario impacting MultiLine users who send WhatsApp messages to Mexico and Argentina numbers.
Scenario
When using MultiLine to message WhatsApp users in Mexico and Argentina, the WhatsApp messaging functionality is disabled for certain phone numbers. Specifically, when these numbers include a prefix after the country code (e.g., "+52 1 386 126 1234" for Mexico), the messaging feature will not work, and a help message displays.
Cause
WhatsApp Business for MultiLine has a limitation where phone numbers that include the prefix after the country code, which is the E.164 international standard, cannot be used for messaging. This affects numbers in Mexico (prefix "1") and Argentina (prefix "9").
Example (Mexico number):
Format including prefix "1": "+52 1 386 126 1234"
Format required for WhatsApp Messaging: "+52 386 126 1234"
Note: to prevent WhatsApp messaging errors, MultiLine automatically disables the messaging feature for numbers that include the prefix and displays the help message.
Workaround
To ensure seamless communication, we recommend saving two entries of the contact's phone number:
Example:
- For calling or SMS, save the number with the prefix, for example "+52 1 386 126 1234"
- For WhatsApp messaging, save the number without the prefix, for example "+52 386 126 1234"
With two separate entries for each contact, you can easily send WhatsApp messages without encountering errors.